We were unable to load Disqus. If you are a moderator please see our troubleshooting guide.

JBM • 10 months ago

An experimental port of Chris Done's tryhaskell UI to the tech.io platform. From my testing, it worked fine before it was published, but judging by the feedback from the generous testers in CG-Chat's #general_fr (thanks to them), it seems to run in platform chaos every now and then. (Service unavailable, console entries not reaching backend and whatever else)

Debug help welcome!

(I'd usually welcome content suggestions as well, but considering this is imported work I'd rather not diverge)

player_one • 10 months ago

Also, the links in the viewer act strangely. The Haskell link works, but loads in the viewer. The Chris Done link doesn't work at all, unless you open it in a new window. Same with the link to the book at the end of the tutorial. I think the difference is that the two non-functioning links don't have an `http://` in front of them. You might want to try tossing a `target="_blank"` into all the links as well, see if it works.

JBM • 10 months ago

I've updated the four links I found (the two in the footer, and the inner ones from the first and last page) to target=_blank, and that seems to do the trick. Regardless of http:// (which I haven't touched)

Thanks!

player_one • 10 months ago

Worked fine for me. I went through the whole tutorial without a hiccup. It times out after 120s of inactivity, but when that happens, it's obvious: "Interrupted due to inactivity, run again to restart it"

JBM • 10 months ago

(and I've cleaned up the sequence to have the "TECHIO> open" command come out guaranteed *after* the server has started. As opposed to the previous race condition. Hoping this might be the cause for the "service unavailable" class of errors that had been reported initially)

Marchete • 9 months ago

Got a "service unavailable" today, on: https://tech.io/playgrounds... , even with a rerun

JBM • 9 months ago

I realize re-reading this thread that I slightly misinterpreted your comment. What I should have answered is:

Thank you for your report! (as unfortunate as the news is to me).

JBM • 9 months ago

Service unavailable is really out of my control until proved otherwise. Just run again until it works?

Techio staff, some hint please?

Thibaud Jobert • 9 months ago

We haven't managed to reproduce this issue yet.

cup_of_tea • 9 months ago

Am I the only one shocked by this initiative?
How many iframes with external contents will be used on tech.io? (without consent is severely wrong, and even with, why not just give the link?)